Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

60 hp johnson tilt and trim not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 60 hp johnson tilt and trim not working

    Hey guys! I have a 1973 65hp johnson and the power tilt worked when I hooked it up to my pontoon a few weeks ago but now it is not working. I have a brand new switch for it also I traced back my wiring to the original trim motor units wiring and hooked the battery up there but still did not work? Does anyone know how to go about fixing one of these?

  • #2
    Re: 60 hp johnson tilt and trim not working

    Does the moter run when you activate the switch, but the unit will not lift the engine?

    Comment


    • #3
      Re: 60 hp johnson tilt and trim not working

      No it does not make any sound. It worked great a few weeks ago.

      Comment


      • #4
        Re: 60 hp johnson tilt and trim not working

        I have no idea what your relay box looks like but my 60 had a set of contact points in there and they had burnt up. One week it worked fine, a month later no. I just sanded them and that was it needed to bring back to action

        Comment


        • #5
          Re: 60 hp johnson tilt and trim not working

          Click image for larger version

Name:	Image.jpg
Views:	1
Size:	84.1 KB
ID:	7105175

          This is what it looks like, and yes that could be what is wrong. I just don't trust myself enough with this stuff yet to start taring it apart without someones opinion.

          Comment


          • #6
            Re: 60 hp johnson tilt and trim not working

            Check or jump your new switch to be sure it isn't defective. If you're getting power to the motor, then you'll have to take the motor off and apart. On mine I cleaned the cracks between the commutator (copper surface where the brushes ride), put it back together and the motor raced up and down.

            Bill
            Last edited by Big Fish Billy; April 8th, 2014, 05:51 AM.
            It is better to be silent and thought a fool,
            Than to speak and remove all doubt...

            If you can't find the time to do it right,
            Where will you find the time to do it over?

            A Craftsman always does it right,
            Because he doesn't know any other way....

            If at first you don't succeed,
            Don't take up skydiving....

            Comment


            • #7
              Re: 60 hp johnson tilt and trim not working

              Yes I hooked a battery straight up to the trim motor it's self and still got nothing

              Comment


              • #8
                Re: 60 hp johnson tilt and trim not working

                Try tapping the trim motor with a screwdriver handle to see if the brushes are stuck; if no joy then the brushes are probably gone and need replacing or worse, the whole motor needs to be replaced. May find one at a salvage yard. Good luck

                Comment


                • #9
                  Re: 60 hp johnson tilt and trim not working

                  The orange sealer makes it look like it was apart / motor has been replaced.---Might need to take it apart and clean the " thermal overload " contact points inside the top part of the motor.

                  Comment


                  • #10
                    Re: 60 hp johnson tilt and trim not working

                    Ok I have all day tomorrow and I will try all of these things and let you guys know my results thanks!!

                    Comment


                    • #11
                      Re: 60 hp johnson tilt and trim not working

                      How can I take the motor off? Can I remove all of the hook ups without anything happening

                      Comment


                      • #12
                        Re: 60 hp johnson tilt and trim not working

                        Remove the electrical connections from the boat and then loosen the two screws on top of the motor and try to take if off in one piece.

                        Comment


                        • #13
                          Re: 60 hp johnson tilt and trim not working

                          I inspected the inside and it appears that the brushes are bad. One is ripped off of its wire and the other the metal piece is broke in half. Is it east to replace these brushes or would i i just be better off buy a new motor?

                          Comment


                          • #14
                            Re: 60 hp johnson tilt and trim not working

                            Carry it to a starter/generator shop and see if they can replace the brushes; if not they can probably tell you where to carry it. Good luck

                            Comment


                            • #15
                              Sign up today
                              Re: 60 hp johnson tilt and trim not working

                              I'd have to say, get a new mtr and then you're done with it. Unless a shop can repair it for a reasonable price. Get an estimate.

                              Comment

                              Working...
                              X